Current Server Time: 20:20 (Central Europe)

#apertus IRC Channel Logs

2020/06/20

Timezone: UTC


00:04
Bertl_oO
(i.e. is the running kernel also your kernel :)
00:18
RexOrCine
left the channel
00:18
RexOrCine
joined the channel
00:36
RexOrCine
left the channel
01:17
RexOrCine
joined the channel
01:22
RexOrCine1
joined the channel
01:22
RexOrCine
left the channel
01:32
RexOrCine
joined the channel
01:34
RexOrCine1
left the channel
02:48
rahul_vinus
left the channel
02:48
mithro
left the channel
02:49
Guest27507
left the channel
02:51
Guest27507
joined the channel
02:53
rahul_vinus
joined the channel
02:58
mithro
joined the channel
03:21
Bertl_oO
off to bed now ... have a good one everyone!
03:22
Bertl_oO
changed nick to: Bertl_zZ
07:23
BAndiT1983|away
changed nick to: BAndiT1983
09:30
mumptai
joined the channel
10:50
Bertl_zZ
changed nick to: Bertl
10:50
Bertl
morning folks!
10:53
bluez_[m]
morning!
10:53
bluez_[m]
> bluez_: did you check the kernel version?
10:53
bluez_[m]
the first thing i checked... seems to be the same...
10:54
bluez_[m]
Unless some config or some in-tree modules changed that i am not aware of...
10:58
se6ast1an
metal_dent[m]: can you update me on the current status of https://github.com/apertus-open-source-cinema/AXIOM-Remote/pull/17 ?
10:58
mumptai
left the channel
10:59
mumptai
joined the channel
11:13
Bertl
bluez_[m]: if it is the kernel you compiled, then you should know what you changed :)
11:16
metal_dent[m]
se6ast1an: simplifying the calculations which are done again..
11:16
se6ast1an
great, I see you just pushed
11:17
metal_dent[m]
no no, there were some conflicts so i solved them and pushed now
11:21
bluez_[m]
<Bertl "bluez_: if it is the kernel you "> okay lemme try copying over my kernel again...
11:22
BAndiT1983
changed nick to: BAndiT1983|away
11:40
bluez_[m]
i am getting kernel panic...
11:41
Bertl
first custom kernel bug?
11:41
bluez_[m]
i copied over my zImage_test and its modules again... but still happens..
11:41
Bertl
when you load your kernel module?
11:41
bluez_[m]
<Bertl "first custom kernel bug?"> i guess ':D
11:41
bluez_[m]
<Bertl "when you load your kernel module"> no on boot
11:42
Bertl
so a bad kernel then?
11:42
Bertl
what's the kernel panic? (pastebin)
11:42
bluez_[m]
but how... i haven't changed nything with my kernel at all
11:43
bluez_[m]
ok, a min..
11:43
Bertl
something will have changed ...
11:45
bluez_[m]
https://pastebin.com/NNE9UufD
11:46
Bertl
kernel stack corruption ... nice (btw, raw url is better ;)
11:47
Bertl
well, boot the golden image and double check the kernel files
11:47
Bertl
and the modules
11:47
bluez_[m]
okay..
11:47
Bertl
probably best way is with rsync or individual md5sums
11:48
Bertl
also rebuilding your kernel might be a good idea just to double check
11:52
Bertl
btw, messages are cut-off, you might want to enable line wrapping in minicom
12:00
Bertl
off for now ... bbs
12:00
Bertl
changed nick to: Bertl_oO
12:01
bluez_[m]
ok it booted... was some issue with the copying of modules ':D
12:02
bluez_[m]
bdw can you remind me of that overkill rsync command you use?
12:02
bluez_[m]
i might want to etch it into my brain xD
12:05
bluez_[m]
alright my driver loads now... so it was some issue with the kernel which was there... but i dont remember changing anything...
12:07
bluez_[m]
<Bertl "kernel stack corruption ... nice"> ah i realized there is a seperate raw url... will send that next time :)
13:08
Spirit532
left the channel
13:32
BAndiT1983|away
changed nick to: BAndiT1983
14:56
Bertl_oO
bluez_[m]: rsync -axXHPSD --numeric-ids
15:01
BAndiT1983
changed nick to: BAndiT1983|away
16:56
vup
bluez_[m]: maybe some compiler version changed? I think the stack guard stuff gets automatically enabled with newer gcc (8+ or something like that)
17:02
BAndiT1983|away
changed nick to: BAndiT1983
17:07
bluez_[m]
> bluez_: rsync -axXHPSD --numeric-ids
17:07
bluez_[m]
Thanks!!
17:12
bluez_[m]
> bluez_: maybe some compiler version changed? I think the stack guard stuff gets automatically enabled with newer gcc (8+ or something like that)
17:12
bluez_[m]
Oh i see... but one thing i found is that the kernel i put there before had a different hash when i checked it with the original... dunno how that happened :/
17:13
bluez_[m]
Nd once i copied over the modules and image again my module loaded successfully... (i didn't even recompile them, same as what i compiled a month back)
17:15
alex[m]24
joined the channel
17:21
BAndiT1983
changed nick to: BAndiT1983|away
17:24
BAndiT1983|away
changed nick to: BAndiT1983
18:18
vup
Hmm interesting
18:48
LordVan
left the channel
18:49
LordVan_
left the channel
19:09
BAndiT1983
changed nick to: BAndiT1983|away
19:22
BAndiT1983|away
changed nick to: BAndiT1983
20:20
Spirit532
joined the channel
20:34
BAndiT1983
changed nick to: BAndiT1983|away
21:11
mumptai
left the channel
22:06
BAndiT1983|away
changed nick to: BAndiT1983
23:02
BAndiT1983
changed nick to: BAndiT1983|away