Current Server Time: 03:12 (Central Europe)

#apertus IRC Channel Logs

2018/10/19

Timezone: UTC


02:12
illwieckz_
joined the channel
02:15
illwieckz
left the channel
02:38
illwieckz_
changed nick to: illwieckz
03:16
illwieckz
left the channel
03:16
illwieckz
joined the channel
03:20
illwieckz_
joined the channel
03:24
illwieckz
left the channel
04:23
Bertl_oO
04:23
Bertl_oO
04:23
Bertl_oO
04:23
Bertl_oO
04:23
Bertl_oO
06:03
BAndiT1983|away
changed nick to: BAndiT1983
07:10
niteesh
joined the channel
07:55
se6astian|away
changed nick to: se6astian
07:56
se6astian
good day
07:58
comradekingu
God dag :)
08:06
RexOrCine|away
changed nick to: RexOrCine
08:06
RexOrCine
Slept in again?
08:22
se6astian
changed nick to: se6astian|away
08:32
comradekingu
I was up slacking off work before work even began, so ummm
08:32
comradekingu
Time is irrelevant with my level of dedication
08:36
RexOrCine
Yeah it's 9:30 am here, my bed time.
08:40
comradekingu
Keep on clocking in the reee world
08:43
RexOrCine
changed nick to: RexOrCine|away
08:45
niteesh
left the channel
08:49
se6astian|away
changed nick to: se6astian
09:13
kelly
joined the channel
09:24
kelly
left the channel
09:27
sebix
joined the channel
09:27
sebix
left the channel
09:27
sebix
joined the channel
09:59
kelly
joined the channel
10:07
futarisIRCcloud
left the channel
11:00
Bertl_oO
11:00
Bertl_oO
11:01
Bertl_oO
hey kelly! how's going?
11:09
kelly
Hey Herbert! Everything is setup for the test. Would you be available around 13pm ?
11:12
Bertl_oO
having a hard time parsind 13pm :)
11:12
Bertl_oO
*parsing
11:12
Bertl_oO
but I will be around for some time
11:46
BAndiT1983
changed nick to: BAndiT1983|away
12:16
kelly
Ok, tell us then when it will be the best moment for you , thanks !
12:16
Bertl_oO
now :)
12:16
Bertl_oO
what equippment did you get?
12:17
Bertl_oO
*equipment
12:17
kelly
benchtop powersupply
12:18
kelly
and ceramic screw driver
12:18
kelly
voltmeter
12:18
Bertl_oO
good, got the cables to connect it?
12:18
kelly
yes also
12:19
Bertl_oO
maybe take a quick snapshot what you've got and upload it to imgur.com or so
12:19
kelly
ok :)
12:23
kelly
do you want to work with webcam?
12:23
kelly
would it be convenient ?
12:24
kelly
photos are sent through mail
12:25
Bertl_oO
there is a reason why I suggested an image upload service, it makes things a lot faster
12:26
kelly
ok
12:29
Bertl_oO
okay, looks reasonably good on the power supply side
12:29
Bertl_oO
have you got some connetors to probe the headers?
12:30
Bertl_oO
(don't see anything suitable on the images)
12:32
Bertl_oO
*connectors
12:33
kelly
me made something to connect
12:33
kelly
what do you call header
12:33
kelly
https://imgur.com/a/Ck23j2S
12:34
kelly
?
12:34
Bertl_oO
https://wiki.apertus.org/images/f/f4/BetaPowerBoard_0.18_TOP.jpg
12:35
Bertl_oO
okay, check out this (old) power board, you see the eight holes in each corner
12:35
Bertl_oO
?
12:38
kelly
https://imgur.com/a/FjvP0Ta
12:38
kelly
ok yes we see it
12:40
Bertl_oO
you need to probe through two of those holes into the power board headers
12:40
kelly
okk, we understand better now thanks
12:40
Bertl_oO
for that you need something like the golden pins on the interface board
12:41
Bertl_oO
but they do not need to be that long, so a 'normal' 2.54mm pin header will do nicely
12:42
Bertl_oO
you want to probe the leftmost pair on the top right header
12:42
Bertl_oO
i.e. the one right beside the 'NE' label
12:44
kelly
ok the pair is one "hole" from the top line and one from the bottom line ? (still the leftmost)
12:45
Bertl_oO
sec, I'll draw you a picture
12:47
kelly
https://imgur.com/a/SJNwigO
12:49
kelly
like this ?
12:51
Bertl_oO
https://imgur.com/a/SDdW4GF
12:51
kelly
thanks
12:52
Bertl_oO
be careful that the 'cables' or whatever you stick in there do not go too far in
12:52
Bertl_oO
otherwise they will touch the MicroZed and potentially destroy stuff
12:52
Bertl_oO
as I said, a typical 2.54mm header would be best
12:53
kelly
yes, we are not in contact with the MicroZed card
12:53
Bertl_oO
https://a.pololu-files.com/picture/0J6427.600x480.jpg
12:54
Bertl_oO
anyway, you need to power up the MicroZed and logon to the device to enable and check the voltages/settings and
12:54
Bertl_oO
the first step is to limit your bench top power supply to 3A and set it to 5V
12:54
Bertl_oO
then power the two boards and check the power consumption given by the bench-top supply
12:55
Bertl_oO
compar that with the reading from ./pac1720_info.sh
12:55
Bertl_oO
(voltage and current)
12:59
kelly
5V 492mA on benctop
13:01
kelly
https://pastebin.com/D9KQcAnJ
13:02
Bertl_oO
good that looks perfect
13:02
Bertl_oO
okay, now let's power up the rails
13:02
Bertl_oO
./power_init.sh
13:03
Bertl_oO
./gpio.py init
13:03
Bertl_oO
./power_on.sh
13:03
Bertl_oO
check again with the benchtop and ./pac1720_info.sh
13:03
Bertl_oO
also measure the output of the pin header pair with the multimeter
13:05
kelly
https://pastebin.com/q3d4fvBA
13:05
kelly
494mA on benchtop
13:06
kelly
1.90V on the pair
13:08
Bertl_oO
do you happen to have an electronic load at hand as well?
13:09
Bertl_oO
or maybe just a power resistor to stress the rail a little bit?
13:10
kelly
what do you means ?
13:12
kelly
giving more power? or add an extra benchtop powersupply?
13:16
Bertl_oO
no, what I mean is to put some stress (i.e. draw some power) from the rail
13:16
Bertl_oO
(the one you are measuring right now)
13:17
Bertl_oO
in any case, we can do without, but it might provide some insight
13:18
kelly
how do you do that? practicaly speaking?
13:18
Bertl_oO
well, as I said, one option is to use an electronic load
13:19
Bertl_oO
another option is to use a power resistor, e.g. something with 50Ohm and 10W or so
13:19
Bertl_oO
anyway, if you do not have any of those at hand, let's just re-adjust the rail and see how that goes with the stack
13:20
kelly
ok
13:20
kelly
let's jump on the next option because we don't have extra electronic load at hand
13:20
Bertl_oO
the trimmer can be turned 360° so there is no end or beginning per se
13:21
Bertl_oO
when you turn the trimmer, the voltage on the rail will start changing (multimeter)
13:21
Bertl_oO
you want to make sure only to adjust this specific rail (i.e. the N_VN trimmer)
13:22
Bertl_oO
you also want to turn it one complete 360° turn around to make sure the electric contact ist good
13:22
kelly
ok
13:22
Bertl_oO
then try to adjust it as good as possible to 1.9V again
13:22
kelly
wich trimmer is the one corresponding to the N_VN ?
13:23
kelly
TR3
13:23
kelly
?
13:23
Bertl_oO
the one I marked on the picture (TR3 :)
13:24
kelly
yes, sorry we just re-saw the picture after the question :)
13:27
kelly
360°
13:27
kelly
clockwise
13:28
kelly
now 2,2v
13:29
kelly
we passed through a maximum voltage of 3v
13:30
kelly
starting position 1,8v, then 90° 1,6v, then 90° 3v, the 180° initial position 2,2v
13:31
kelly
We forgot to tell you, yesturday, when we stoped with the camera, the sensor was very hot.. i almost burnt my finger touching it
13:33
Bertl_oO
that is unusual and might point towards a defective sensor
13:33
Bertl_oO
anyway, you need to adjust the trimmer till you reach 1.9V
13:34
Bertl_oO
it can be tricky as the range is quite small
13:34
Bertl_oO
just turn very slowly and watch the multimeter
13:35
kelly
ok, back to 1,9
13:37
kelly
how can i check if the sensor is defective?
13:38
Bertl_oO
that's always tricky
13:38
kelly
I don't have any spare sensor
13:38
kelly
if yes, i would test with another one
13:39
Bertl_oO
okay, let's do some more tests on the power board just to make sure
13:39
kelly
ok
13:45
illwieckz_
left the channel
13:45
illwieckz
joined the channel
13:46
BAndiT1983|away
changed nick to: BAndiT1983
13:46
Bertl_oO
okay, let's put the stack back together and see what we get
13:47
Bertl_oO
also double check that the sensor is inserted the right way around and in the right position
13:48
Bertl_oO
double check that the interface board is facing up (i.e. the arrows point towards the top of the camera)
13:48
kelly
ok, we put all back + the sensor ?
13:48
Bertl_oO
yes, including the sensor, let's see what we get on the power rail
13:51
illwieckz
left the channel
13:57
kelly
ok, everything is back together and the power is on
13:59
Bertl_oO
good, let's start simple with
13:59
Bertl_oO
./power_init.sh
13:59
Bertl_oO
./gpio.py init
13:59
Bertl_oO
./power_on.sh
13:59
Bertl_oO
sleep 5
13:59
Bertl_oO
./pac1720_info.sh
14:00
Bertl_oO
also check if the sensor is getting hot fast
14:00
kelly
https://pastebin.com/LLVwHzTA
14:00
kelly
ok
14:00
Bertl_oO
so the LVDS voltage looks fine now
14:01
Bertl_oO
let's continue with:
14:01
kelly
good news already
14:01
Bertl_oO
cat cmv_hdmi3.bit >/dev/xdevcfg
14:01
Bertl_oO
sleep 5
14:01
Bertl_oO
./pac1720_info.sh
14:02
kelly
https://pastebin.com/yU5tWkgA
14:02
Bertl_oO
still looking good, what about
14:02
kelly
(sensor normally hot for now)
14:02
Bertl_oO
./cmv_init.sh
14:03
Bertl_oO
what's the return value you get?
14:03
kelly
still 0x00000000
14:03
Bertl_oO
too bad, would have been nice
14:03
Bertl_oO
what about
14:03
kelly
yes...
14:03
Bertl_oO
./pac1720_info.sh
14:04
kelly
https://pastebin.com/XweTQHaJ
14:05
Bertl_oO
okay, let's reboot the Beta and give the kick_manual a try
14:05
Bertl_oO
./kick_manual.sh
14:05
kelly
reboot just with power off/power on ?
14:06
Bertl_oO
yeah, that's fine
14:07
kelly
(also, do you know why a password is asked now when we try to connect with ssh ? or if you know the password ?)
14:07
Bertl_oO
you need to add your ssh key to the Beta to logon via ssh
14:08
Bertl_oO
i.e. password access is disabled by default
14:08
Bertl_oO
https://wiki.apertus.org/index.php/AXIOM_Beta/Manual
14:08
kelly
i already added the key, it worked yesterday but not anymore today, even if the key is still in the authorized_key file
14:09
kelly
the ./kick_manual.sh does the same as before
14:09
kelly
the loop
14:09
Bertl_oO
that is unusual, but check the authorized_key file
14:09
Bertl_oO
the permissions on the key file that is
14:09
Bertl_oO
can you pastebin part of the loop for me?
14:10
Bertl_oO
still everything zero there?
14:10
kelly
yes still zero
14:10
Bertl_oO
okay, so the next step would be to use a logic analyzer or scope to verify the SPI interface on the sensor socket
14:11
Bertl_oO
but it might be easier to send us the camera including sensor for general testing, as we have all the equippment needed including loopback adapters
14:12
Bertl_oO
*eqipment
14:12
Bertl_oO
we also can test the sensor in a known working stak and the stack with a known good sensor
14:13
kelly
https://pastebin.com/9FeZTmsP
14:13
kelly
for the loop
14:15
kelly
Yes, indeed, that's exactly the thing we were thinking about, it might be easier to send it to you
14:19
Bertl_oO
okay, let me know what you decide, and when you go for shipping it, let me know so that I can give you my address to speed up things
14:21
kelly
we may ship asap, if it's not this afternoon, it might be monday morning max
14:23
Bertl_oO
okay, I send you my postal address via email then
14:34
kelly
Thanks a lot
14:34
kelly
(the sensor was really hot at the end)
14:35
kelly
it's too late to ship it now so it'll be for monday morning
14:41
Bertl_oO
okay
14:47
kelly
Thanks a lot again, keep in touch for monday
14:47
Bertl_oO
you're welcome!
14:47
Bertl_oO
cya around!
14:47
kelly
Bye !
14:47
kelly
left the channel
15:11
illwieckz
joined the channel
15:13
AbsentFilms
joined the channel
15:25
rahul_
Hello @Bertl
15:27
se6astian
Hi rahul_!
15:27
se6astian
how are you?
15:27
AbsentFilms_
joined the channel
15:30
Bertl_oO
hey rahul_!
15:30
AbsentFilms
left the channel
15:32
se6astian
hi AbsentFilms_
15:32
se6astian
just saw your lab account registration
15:33
se6astian
15:36
illwieckz
left the channel
15:37
AbsentFilms_
left the channel
15:37
illwieckz
joined the channel
15:39
illwieckz
left the channel
15:39
illwieckz
joined the channel
15:41
illwieckz
left the channel
15:41
illwieckz
joined the channel
16:03
sebix
left the channel
16:09
rahul_
hello @sebastian @Bertl I am good, just started my Thesis.
16:10
niteesh
joined the channel
16:10
Bertl_oO
great!
16:11
rahul_
i again started looking into the placement of my peaking IP
16:11
rahul_
and also wanted to discuss the partial reconfiguration project that we had discussed when I was in Vienna
16:15
se6astian
sounds good, Bertl_oO sounds like your man for this
16:17
Bertl_oO
sure, anytime I'm around ...
16:28
se6astian
rahul_: you meant you want to discuss it now didnt you?
16:31
se6astian
off for now
16:31
se6astian
changed nick to: se6astian|away
17:07
rahul_
yes
17:08
rahul_
but i am not able to pm either @sabestian or @Bertl
17:10
se6astian|away
changed nick to: se6astian
17:10
se6astian
thats because your nickname isnt registred with freenode I assume and they stepped up measurements after the recent spam waves
17:11
se6astian
but you can discuss here
17:11
se6astian
or register your nick
17:11
se6astian
or choose a channelname of your choice and go there with Bertl_oO
17:12
rahul_
ok
17:48
niemand
joined the channel
17:48
niemand
left the channel
17:48
niemand
joined the channel
18:22
illwieckz_
joined the channel
18:28
illwieckz_
left the channel
18:42
illwieckz
left the channel
18:50
RexOrCine|away
changed nick to: RexOrCine
18:52
illwieckz
joined the channel
19:20
illwieckz
left the channel
19:20
BAndiT1983
changed nick to: BAndiT1983|away
19:20
BAndiT1983|away
changed nick to: BAndiT1983
19:21
illwieckz
joined the channel
19:22
illwieckz
left the channel
19:23
illwieckz
joined the channel
19:26
niteesh
left the channel
19:37
BAndiT1983
changed nick to: BAndiT1983|away
20:07
RexOrCine
changed nick to: RexOrCine|away
20:34
illwieckz
left the channel
20:34
illwieckz
joined the channel
20:58
illwieckz
left the channel
21:10
illwieckz
joined the channel
21:34
illwieckz
left the channel
21:36
illwieckz
joined the channel
21:42
niemand
left the channel
23:22
se6astian
changed nick to: se6astian|away
00:55
AbsentFilms
joined the channel