Current Server Time: 03:14 (Central Europe)

#apertus IRC Channel Logs

2017/03/07

Timezone: UTC


23:20
d0
left the channel
01:10
jucar
joined the channel
01:41
arpu
joined the channel
02:33
jucar
left the channel
02:53
Bertl_oO
off to bed now ... have a good one everyone!
02:53
Bertl_oO
changed nick to: Bertl_zZ
03:01
arpu
left the channel
05:53
Bertl_zZ
changed nick to: Bertl
05:54
Bertl
morning folks!
06:36
dimaursu16
joined the channel
06:36
dimaursu16
left the channel
06:36
dimaursu16
joined the channel
07:04
se6astian|away
changed nick to: se6astian
07:05
dimaursu16
left the channel
07:25
dimaursu16
joined the channel
07:25
dimaursu16
left the channel
07:25
dimaursu16
joined the channel
07:44
Roopal08
joined the channel
07:48
Roopal08
Hey ,I was busy during the weekend with some assignments ,so couldn't be in touch . BAndiT1983 I have build OpenCine using the build instructions.
07:50
Roopal08_
joined the channel
07:52
Roopal08
left the channel
07:53
Roopal08_
left the channel
07:53
Roopal08
joined the channel
07:55
Roopal08
I have build it from command line , building from Qtcreator was throwing up an error .
08:00
ItsMeLenny
joined the channel
08:01
Roopal08
left the channel
08:04
IldarValiev
joined the channel
08:15
AndChat|110000
joined the channel
08:16
AndChat|110000
left the channel
08:16
AndChat|110000
joined the channel
08:16
AndChat|110000
left the channel
08:17
AndChat|110000
joined the channel
08:18
IldarValiev
left the channel
08:20
AndChat|110000
left the channel
08:21
IldarValiev
joined the channel
08:28
Bertl
hello IldarValiev!
08:33
d0
joined the channel
08:41
IldarValiev_
joined the channel
08:41
IldarValiev_
left the channel
08:41
Spirit532
joined the channel
08:56
IldarValiev
left the channel
08:59
IldarValiev
joined the channel
09:01
IldarValiev
left the channel
09:01
IldarValiev
joined the channel
09:18
IldarValiev
left the channel
09:44
Roopal08
joined the channel
09:48
Roopal08
while building from command line , I am getting an error while running the command make -J4 . Here is the error http://pastebin.com/8tX5aCHR
09:50
Roopal08
Will you please help me in fixing this up .
09:52
ItsMeLenny
left the channel
10:03
Spirit532
left the channel
10:03
Spirit532
joined the channel
10:16
Bertl
off for now ... bbl
10:16
Bertl
changed nick to: Bertl_oO
10:24
Roopal08
left the channel
10:26
dimaursu16
left the channel
10:45
Elbehery
joined the channel
10:50
Elbehery
left the channel
11:48
dimaursu16
joined the channel
11:48
dimaursu16
left the channel
11:48
dimaursu16
joined the channel
12:33
se6astian
changed nick to: se6astian|away
12:44
IldarValiev
joined the channel
12:59
IldarValiev
left the channel
13:15
RexOrCine
joined the channel
13:19
dimaursu16
left the channel
13:32
se6astian|away
changed nick to: se6astian
14:14
arpu
joined the channel
14:19
BAndiT1983
joined the channel
14:23
jucar
joined the channel
14:25
se6astian
new article released: https://www.apertus.org/apertus-google-summer-of-code-article-march-2017
14:29
BAndiT1983
nice one
14:42
Roopal08
joined the channel
14:43
Roopal08
Hey BAndiT1983, I needed your help.
14:44
Roopal08
while building OpenCine from command line , I am getting an error while running the command make -J4 . Here is the error http://pastebin.com/8tX5aCHR .
14:44
BAndiT1983
compiled some minutes ago
14:44
BAndiT1983
no error here, works on both ends
14:44
BAndiT1983
please paste the whole build log and not just excerpt
14:46
Roopal08
okkay . Just 1 min
14:46
BAndiT1983
i will compare the cmake files, as i'm not at home and cannot access original data, just some copy which i have on the laptop
14:46
BAndiT1983
but your build tells me, that it hasn't downloaded QtAV from repository, which should be done automatically while building
14:48
BAndiT1983
se6astian: i've checked ffmpeg support for MLV, but somehow it#s not very well supported, so i will read through ML forum to see if there is something to simplify the task, possibly some conversion of the raw viewer which alexML mentioned
14:52
Roopal08
This is the complete log - http://pastebin.com/winQAfME
14:54
intracube_afk
changed nick to: intracube
14:55
jucar
left the channel
14:58
BAndiT1983
Roopal08: not seeing much in your build log, i have same code ersion which is also uploaded and tested it again on clean VM
14:59
Roopal08
actually while doing cmake -DCMAKE_PREFIX_PATH=$HOME/Qt/5.8/gcc_64/lib/cmake/ ../OpenCine I got these warnings - http://pastebin.com/XB41ivtj
14:59
BAndiT1983
as i said, works fine here, have clean VM, clean build folder and so on
15:00
BAndiT1983
build log seems also somehow short, if i build, then it shows a lot of messages
15:01
Roopal08
actually I have already built once before so now , it just shows the once which had errors .
15:02
BAndiT1983
you should clean the OpenCine_build folder first and check it again
15:05
se6astian
changed nick to: se6astian|away
15:08
Roopal08
left the channel
16:00
dimaursu16
joined the channel
16:00
dimaursu16
left the channel
16:00
dimaursu16
joined the channel
16:02
dimaursu16
left the channel
16:02
dimaursu16
joined the channel
16:02
dimaursu16
left the channel
16:02
dimaursu16
joined the channel
16:16
BAndiT1983
left the channel
16:43
RL
left the channel
17:01
RL
joined the channel
17:35
Roopal08
joined the channel
17:37
Roopal08
Hey , this is the complete build log - http://pastebin.com/QywmceKs . I cleaned the OpenCine_build folder and then did again . It still shows same error.
17:40
Roopal08
What I could figure out from this is , in file Source/OpenCine/Source/OCui/Controls/PlaybackSlider.h it is looking for #include<QtAV/QtAV> but it is not there in Qt/5.8/gcc_64/include where it is looking for .
17:42
anuditverma
joined the channel
17:42
RexOrCine
Hi Roopal08 Good stuff. I don't know much about OpenCine I'm afraid. BAndiT1983 normally comes on in the next hour or two.
17:51
karan
joined the channel
17:52
BAndiT1983|away
changed nick to: BAndiT1983
17:52
BAndiT1983
Roopal08, are you still there?
17:52
anuditverma
Hi, I have been following the task changes on idea AXIOM beta REST interface (/T723), earlier it was mentioned that Google protocol buffers would be used for the API implementation but now it has been removed, could you please confirm that it would be used or not ?
17:53
BAndiT1983
flatbuffers will be used, but it shouldn't bother you in first place, as you will get a wrapper, which should simplify the configuration of settings
17:53
karan
left the channel
17:53
BAndiT1983
flatbuffers are the slimmer version of protbuf
17:53
karan
joined the channel
17:53
anuditverma
okay
17:54
BAndiT1983
will upload initial revision and start to implement the communication between daemon (server) and example binding (client)
17:55
BAndiT1983
but first i have to check what's wrong with build of Roopal08 first, as i want to add MagicLantern support soon, but for this task i need a build which is not failing on other machines, or at least know what could go wrong to add troubleshooting section to build instructions
17:56
anuditverma
ok cool, thanks for the help, please continue.
17:57
BAndiT1983
alright, pushed the commit finally, as i wasn't approved for it yesterday, so it says "22 hours ago" -> https://github.com/apertus-open-source-cinema/beta-software/tree/master/axiom_beta_control_daemon
18:00
BAndiT1983
Roopal08, are you still there? i wanted to check if you have the same paths for QtAV, as it should reside in OpenCine_build folder under 3rdParty
18:01
Roopal08
left the channel
18:04
Roopal08
joined the channel
18:04
Roopal08
Hi, I am there
18:04
BAndiT1983
alright
18:04
BAndiT1983
please execute the cmake call, as i'Ve placed there some status messages to verify correct paths
18:05
BAndiT1983
on my VM the path to QtAV source is following one -> /home/dev/Source/OpenCine_build/3rdParty/QtAV/src/QtAV_project/src
18:06
BAndiT1983
there should be QtAV folder underneath and there is QtAV.h
18:06
BAndiT1983
that's also the folder i've included in cmake script
18:07
BAndiT1983
ExternalProject_Get_Property(QtAV_project INSTALL_DIR)
18:07
BAndiT1983
include_directories(${INSTALL_DIR}/src/QtAV/src/)
18:07
BAndiT1983
message(WARNING "QTAV_DIR: ${INSTALL_DIR}/src/QtAV/src/")
18:07
BAndiT1983
include_directories(${INSTALL_DIR}/src/QtAV/widgets/)
18:08
Roopal08
Ok, I got QtAV.h, but the path the playslider is taking is different from this one
18:08
BAndiT1983
which one?
18:08
Roopal08
it is taking this path Qt/5.8/gcc_64/include
18:08
BAndiT1983
that's not good, please paste cmake config execution, so i can check the paths
18:09
karan
left the channel
18:10
Roopal08
http://pastebin.com/qHFjd5qa - cmake config execution
18:11
BAndiT1983
paths seem legit, no problem there, just let me check my paths again
18:12
BAndiT1983
this is my cmake config -> http://pastebin.com/upWm3WRL
18:13
BAndiT1983
CMAKE_PREFIX_PATH is assigned to QTDIR in the main CMakeLists.txt, the one in the root folder of repo
18:14
BAndiT1983
so, it should be pointing to cmake-related qt things
18:14
BAndiT1983
QTAV_DIR is much more interesting, but seems similar to mine
18:15
Roopal08
The root folder means the OpenCine folder in Source ?
18:16
BAndiT1983
yes, you should have the repo in OpenCine folder and the build accordingly in OpenCine_build
18:17
BAndiT1983
this simplifies the life of a developer, of course there are multiple ways where to hold the build, it could also be placed in build folder inside OpenCine, but while committing it's rather tedious to set it on ignore
18:18
BAndiT1983
just wondering if i have to include the header directory in OCui also, but it works on my machine without any hassle, already deleted _build folder and rebuild it all several times today
18:20
Roopal08
This is the CMake of root folder http://pastebin.com/7AdCifVN
18:21
BAndiT1983
let me check out, maybe the branch has shifted somehow
18:29
BAndiT1983
nope, looks the same, compared folder checked out from master and my previous one which based on dev, but i haven't changed anything since the merge, except the readme file
18:29
BAndiT1983
which linux do you use?
18:30
Roopal08
i use elementary os
18:30
BAndiT1983
never tested with it, just linuxmint (ubuntu possibly also works)
18:31
BAndiT1983
which version of compiler do you have? -> g++ --version
18:31
Roopal08
g++ (Ubuntu 4.8.4-2ubuntu1~14.04.3) 4.8.4
18:31
BAndiT1983
g++ (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609
18:31
BAndiT1983
it's possible, that the compiler is old
18:32
BAndiT1983
that's why i said, that you should consider to setup virtualbox VM
18:32
Roopal08
okay , i will upgrade and then check
18:32
BAndiT1983
i will provide pre-configured VM soon, but i need some free time first, so it will take a while
18:33
Roopal08
okay .
18:33
slikdigit
joined the channel
18:53
Roopal08
I upgrded g++ and ran cmake and make command again, still the error is cropping up.
18:55
BAndiT1983
don't know at the moment what to suggest, as it's complicated to do so without seeing it
18:55
BAndiT1983
try to investigate the cause, as i don't have time to install elementary os VM to do it
18:56
BAndiT1983
add SET(CMAKE_VERBOSE_MAKEFILE ON) to the main cmakelists.txt, maybe it helps to get more info on what is causing the problem
18:57
BAndiT1983
reference -> http://stackoverflow.com/questions/12823799/cmake-how-to-show-the-compilers-stdout
19:07
se6astian|away
changed nick to: se6astian
19:12
Roopal08
left the channel
19:14
RexOrCine
left the channel
19:43
anuditverma
left the channel
19:49
anuditverma
joined the channel
20:01
anuditverma
left the channel
20:10
Bertl_oO
off for a nap ... bbl
20:10
Bertl_oO
changed nick to: Bertl_zZ
20:24
Roopal08
joined the channel
20:26
Roopal08
I tried it in Ubuntu 16.04 too .. still I am getting the same error. We have proxy server configured to use internet provided by college, can that create any problem?
20:27
BAndiT1983
if the source for qtav was downloaded and built, there shouldn't be any problem
20:29
BAndiT1983
will check it soon while preparing VM, but at the moment i have to proceed with axiom beta daemon
20:30
Roopal08
Are you talking about this http://download.qt.io/official_releases/qt/5.8/5.8.0/qt-opensource-linux-x64-5.8.0.run?
20:32
BAndiT1983
this is qt, qtav is a library which binds ffmpeg for video decoding to qt
20:38
Roopal08_
joined the channel
20:39
Roopal08_
Can you tell me where should I put QtAV folder after downloading and building it ?
20:45
kaiserlich
joined the channel
20:47
BAndiT1983
it should do it automatically
20:47
BAndiT1983
cmake has its own folder structure and i haven't bothered with restructuring for first tests
20:51
Roopal08
left the channel
20:51
Roopal08_
left the channel
20:53
se6astian
off to bed
20:53
se6astian
good night
20:53
se6astian
changed nick to: se6astian|away
21:07
kaiserlich
left the channel
22:17
Spirit532
left the channel
22:34
BAndiT1983
changed nick to: BAndiT1983|away
22:39
dimaursu16
left the channel